import Foundation
let pattern = #"Subject :\s*([\s\S]*?)(?=\*+end of input\*+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Subject :
So for example, one field can span any number of lines and then there will be a message similar to
****end of input****
It will match anything after the colon until it hits a new line character. This works for almost all of the fields I need to scrape. One however, is a bit more trouble. One of them, the last one I need to scrape (not shown above) will span multiple lines. There's no way to predict how long it will be, but instead I have another predefined piece of text I can use to determine where to stop capturing.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}