package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-z0-9٠-٩\-+,()/'\s\p{Arabic}]{1,60}$`)
var str = `لمحة عن الشركة`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}