const regex = new RegExp('^[a-z0-9٠-٩\\-+,()/\\'\\s\\p{Arabic}]{1,60}$', 'iu')
const str = `لمحة عن الشركة`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}