import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"'])((?:(?=(?:\\\\)*)\\\\.|.)*?)\\1";
final String string = "\" RegExp to match quotes \"\n"
+ "' Supports escapin\\' '\n"
+ "\" This is selected \\\\\" this is not\n"
+ "' Works with JS RegExp '\n"
+ "\"You can also get the quote type used\"\n\n"
+ "\"How it works\"\n"
+ "\"------------\"\n\n"
+ "' ([\"\\']) Matches a \" or a \\' and stores it in \\1'\n"
+ "' ( starts \\2'\n"
+ "' (?: starts a non-capturing group'\n"
+ "' (?=(?:\\\\)*) Will check if there is an odd amount of \\ '\n"
+ "' \\\\. will escape / ignore it '\n"
+ "' |. will never mind it if there\\'s an even amount '\n"
+ "' )*? will close the non-capturing group and repeat it'\n"
+ "' \\1 will make it close with the quote selected in \\1'\n\n"
+ "\"Flags:\"\n"
+ "\"------\"\n\n"
+ "\" g: global, selects multiple times \"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}