import re
regex = re.compile(r"([\"'])((?:(?=(?:\\)*)\\.|.)*?)\1", flags=re.MULTILINE)
test_str = ("\" RegExp to match quotes \"\n"
"' Supports escapin\\' '\n"
"\" This is selected \\\\\" this is not\n"
"' Works with JS RegExp '\n"
"\"You can also get the quote type used\"\n\n"
"\"How it works\"\n"
"\"------------\"\n\n"
"' ([\"\\']) Matches a \" or a \\' and stores it in \\1'\n"
"' ( starts \\2'\n"
"' (?: starts a non-capturing group'\n"
"' (?=(?:\\\\)*) Will check if there is an odd amount of \\ '\n"
"' \\\\. will escape / ignore it '\n"
"' |. will never mind it if there\\'s an even amount '\n"
"' )*? will close the non-capturing group and repeat it'\n"
"' \\1 will make it close with the quote selected in \\1'\n\n"
"\"Flags:\"\n"
"\"------\"\n\n"
"\" g: global, selects multiple times \"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")