using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([2-2]{1}|[6-7]{1})([0-9]{3})[-. ]?(\d{4})?$";
string input = @"78511074";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}