const regex = /^([2-2]{1}|[6-7]{1})([0-9]{3})[-. ]?(\d{4})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([2-2]{1}|[6-7]{1})([0-9]{3})[-. ]?(\\d{4})?$', '')
const str = `78511074`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}