#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/(?:www\.)?decathlon\.co\.id\/([\w.'_-]+(\/([\w-]+))+?).html"
Local $sString = "https://www.decathlon.co.id/in/p/tas-quechua/301684-73330-nh100-10l-country-walking-backpack-black.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")