using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(?:www\.)?decathlon\.co\.id\/([\w.'_-]+(\/([\w-]+))+?).html";
string input = @"https://www.decathlon.co.id/in/p/tas-quechua/301684-73330-nh100-10l-country-walking-backpack-black.html";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}