using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"switchbot\/SwitchBotMQTT\/curtain\/([a-z]+)\/.*";
string input = @"switchbot/SwitchBotMQTT/curtain/curtainone/status";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}