package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)switchbot\/SwitchBotMQTT\/curtain\/([a-z]+)\/.*`)
var str = `switchbot/SwitchBotMQTT/curtain/curtainone/status`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}