re = /switchbot\/SwitchBotMQTT\/curtain\/([a-z]+)\/.*/m
str = 'switchbot/SwitchBotMQTT/curtain/curtainone/status'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end