package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^_.*?\|`)
var str = `CodChamado
_14984|Top Down:
_14985|Hierarquia solicitante:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}