re = /^_.*?\|/m
str = 'CodChamado
_14984|Top Down:
_14985|Hierarquia solicitante:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end