$re = '/^_.*?\|/m';
$str = 'CodChamado
_14984|Top Down:
_14985|Hierarquia solicitante:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);