#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{4}|[0-9]{2})[\/]([0]?[1-9]|[1][0-2])[\/]([0]?[1-9]|[1|2][0-9]|[3][0|1]), ([A|P])M([1-9]|1[0-2]):([0-5]\d) - (.*?): ([\s\S]*?END)$"
Local $sString = "2012/12/1, AM12:21 - user1: entry1END" & @CRLF & _
"2012/12/2, AM9:42 - user2: entry2END" & @CRLF & _
"2012/12/2, AM9:44 - user3: entry3_Line1_ContdWithFollowingLine" & @CRLF & _
"entry3_Line2_ContdWithABoveLine" & @CRLF & _
"entry3_Line3_ContdWithABoveLineEND" & @CRLF & _
"2012/12/4, AM11:48 - user7: entry4END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")