use strict;
my $str = '2012/12/1, AM12:21 - user1: entry1END
2012/12/2, AM9:42 - user2: entry2END
2012/12/2, AM9:44 - user3: entry3_Line1_ContdWithFollowingLine
entry3_Line2_ContdWithABoveLine
entry3_Line3_ContdWithABoveLineEND
2012/12/4, AM11:48 - user7: entry4END';
my $regex = qr/^([0-9]{4}|[0-9]{2})[\/]([0]?[1-9]|[1][0-2])[\/]([0]?[1-9]|[1|2][0-9]|[3][0|1]), ([A|P])M([1-9]|1[0-2]):([0-5]\d) - (.*?): ([\s\S]*?END)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}