re = /^([0-9]{4}|[0-9]{2})[\/]([0]?[1-9]|[1][0-2])[\/]([0]?[1-9]|[1|2][0-9]|[3][0|1]), ([A|P])M([1-9]|1[0-2]):([0-5]\d) - (.*?): ([\s\S]*?END)$/m
str = '2012/12/1, AM12:21 - user1: entry1END
2012/12/2, AM9:42 - user2: entry2END
2012/12/2, AM9:44 - user3: entry3_Line1_ContdWithFollowingLine
entry3_Line2_ContdWithABoveLine
entry3_Line3_ContdWithABoveLineEND
2012/12/4, AM11:48 - user7: entry4END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end