package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+\.\d+)\s*w:`)
var str = `ID: 1 x: 1202 y: 2453.6756667756 w: 242`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}