$re = '/(\d+\.\d+)\s*w:/';
$str = 'ID: 1 x: 1202 y: 2453.6756667756 w: 242';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);