const regex = /(\d+\.\d+)\s*w:/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.\\d+)\\s*w:', '')
const str = `ID: 1 x: 1202 y: 2453.6756667756 w: 242`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}