use strict;
my $str = '{
"destination_addresses" : [ "Bramfelder Chaussee 1, 22177 Hamburg, Deutschland" ],
"origin_addresses" : [ "Hasselbusch 1, 22941 Bargteheide, Deutschland" ],
"rows" : [
{
"elements" : [
{
"distance" : {
"text" : "19,8 km",
"value" : 19767
},
"duration" : {
"text" : "31 Minuten",
"value" : 1830
},
"duration_in_traffic" : {
"text" : "30 Minuten",
"value" : 1777
},
"status" : "OK"
}
]
}
],
"status" : "OK"
}
';
my $regex = qr/(?s)duration.* "(.* Minuten).*duration_in/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}