$re = '/(?s)duration.* "(.* Minuten).*duration_in/m';
$str = '{
"destination_addresses" : [ "Bramfelder Chaussee 1, 22177 Hamburg, Deutschland" ],
"origin_addresses" : [ "Hasselbusch 1, 22941 Bargteheide, Deutschland" ],
"rows" : [
{
"elements" : [
{
"distance" : {
"text" : "19,8 km",
"value" : 19767
},
"duration" : {
"text" : "31 Minuten",
"value" : 1830
},
"duration_in_traffic" : {
"text" : "30 Minuten",
"value" : 1777
},
"status" : "OK"
}
]
}
],
"status" : "OK"
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);