import Foundation
let pattern = #"(?s)duration.* "(.* Minuten).*duration_in"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"destination_addresses" : [ "Bramfelder Chaussee 1, 22177 Hamburg, Deutschland" ],
"origin_addresses" : [ "Hasselbusch 1, 22941 Bargteheide, Deutschland" ],
"rows" : [
{
"elements" : [
{
"distance" : {
"text" : "19,8 km",
"value" : 19767
},
"duration" : {
"text" : "31 Minuten",
"value" : 1830
},
"duration_in_traffic" : {
"text" : "30 Minuten",
"value" : 1777
},
"status" : "OK"
}
]
}
],
"status" : "OK"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)