using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^\d\n]*\d)(\d+)?[^\d\n]*(?:\((\d*)\))?[^\d\n]*$";
string input = @"all valid combinations
123(456)
123
(456)
abc(456)
123(efg)
these are not valid
abc(efg)
abc
(efg)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}