$re = '/^(?=[^\d\n]*\d)(\d+)?[^\d\n]*(?:\((\d*)\))?[^\d\n]*$/m';
$str = 'all valid combinations
123(456)
123
(456)
abc(456)
123(efg)
these are not valid
abc(efg)
abc
(efg)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);