const regex = /^(?=[^\d\n]*\d)(\d+)?[^\d\n]*(?:\((\d*)\))?[^\d\n]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^\\d\\n]*\\d)(\\d+)?[^\\d\\n]*(?:\\((\\d*)\\))?[^\\d\\n]*$', 'gm')
const str = `all valid combinations
123(456)
123
(456)
abc(456)
123(efg)
these are not valid
abc(efg)
abc
(efg)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}