#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([([])[A-Za-z]+[\])]|[^\[()\]]+"
Local $sString = "none[square](round)(accept]able)[wrong)" & @CRLF & _
"none" & @CRLF & _
"[square]" & @CRLF & _
"(round)" & @CRLF & _
"(accept]able)" & @CRLF & _
"[wrong)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")