using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([([])[A-Za-z]+[\])]|[^\[()\]]+";
string input = @"none[square](round)(accept]able)[wrong)
none
[square]
(round)
(accept]able)
[wrong)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}