re = /([([])[A-Za-z]+[\])]|[^\[()\]]+/m
str = 'none[square](round)(accept]able)[wrong)
none
[square]
(round)
(accept]able)
[wrong)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end