import re
regex = re.compile(r"(?:id=\"ImportGridView\"Index: )(.)(?:Name:)")
test_str = "AgCocoaBridgeView id=\"ImportGridView\"Index: 1Name: 1SingleImport.CR2{15,223,193,253} = Index: 1Name: 1SingleImport.CR2 = Index: 1Name: 1SingleImport.CR2"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")