re = /(?:id="ImportGridView"Index: )(.)(?:Name:)/
str = 'AgCocoaBridgeView id="ImportGridView"Index: 1Name: 1SingleImport.CR2{15,223,193,253} = Index: 1Name: 1SingleImport.CR2 = Index: 1Name: 1SingleImport.CR2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end