# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http(?:s)?\://boards\.4chan\.org/([a-z]*)/thread/([0-9]*)(?:\#[0-9a-z]*)?"
test_str = ("https://boards.4chan.org/mlp/thread/5\n"
"http://boards.4chan.org/b/thread/570277846\n"
"https://boards.4chan.org/mlp/thread/19865655#q19865655\n"
"https://boards.4chan.org/mlp/thread/19775771\n"
"https://boards.4chan.org/co/thread/65737750#q65737750")
subst = "Thread $2 on mlp"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.