package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/\*[\s\S]*\*/`)
var str = `/* first line.
the second line
The last line. */
/* asdlfas;dlf */
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}