using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\({1,4}[9][\*\-\+\/][9]\)?[\*\-\+\/][9]\){0,2}[\*\-\+\/][9]\){0,1}";
string input = @"(9+9+9+9)
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}