import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\({1,4}[9][\\*\\-\\+\\/][9]\\)?[\\*\\-\\+\\/][9]\\){0,2}[\\*\\-\\+\\/][9]\\){0,1}";
final String string = "(9+9+9+9)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}