re = /^\({1,4}[9][\*\-\+\/][9]\)?[\*\-\+\/][9]\){0,2}[\*\-\+\/][9]\){0,1}/
str = '(9+9+9+9)
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end