#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:.*?\/(\d+))?.*$"
Local $sString = "/text/other_text/123-some_other_txet-4571/text.html" & @CRLF & _
"/text/other_text/another_txet/15-some_other_txet.html" & @CRLF & _
"/text/other_text/25189-some_other_txet/45112-text.html" & @CRLF & _
"/text/other_text/text/text/5418874-some_other_txet.html" & @CRLF & _
"/text/other_text/text/text/some_other_txet-4157/text.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)