const regex = /^(?:.*?\/(\d+))?.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*?\\\/(\\d+))?.*$', 'gm')
const str = `/text/other_text/123-some_other_txet-4571/text.html
/text/other_text/another_txet/15-some_other_txet.html
/text/other_text/25189-some_other_txet/45112-text.html
/text/other_text/text/text/5418874-some_other_txet.html
/text/other_text/text/text/some_other_txet-4157/text.html`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);