import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?\\/(\\d+))?.*$";
final String string = "/text/other_text/123-some_other_txet-4571/text.html\n"
+ "/text/other_text/another_txet/15-some_other_txet.html\n"
+ "/text/other_text/25189-some_other_txet/45112-text.html\n"
+ "/text/other_text/text/text/5418874-some_other_txet.html\n"
+ "/text/other_text/text/text/some_other_txet-4157/text.html";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}