using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*@(example1\.com|example2\.org|example3\.net)\b)(?:(?:To:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,})|(?:CC:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,}))";
string input = @"To:jerry@example1.com,larry@example1.com,berry@example1.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}