use strict;
my $str = 'To:jerry@example1.com,larry@example1.com,berry@example1.com';
my $regex = qr/^(?!.*@(example1\.com|example2\.org|example3\.net)\b)(?:(?:To:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,})|(?:CC:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}