const regex = /((?:19|[2-9][0-9])[0-9]{2})-(1[0-2]|0[1-9])-(3[01]|[12][0-9]|0[1-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:19|[2-9][0-9])[0-9]{2})-(1[0-2]|0[1-9])-(3[01]|[12][0-9]|0[1-9])', 'gm')
const str = `1900-01-01 Y
9999-12-31 Y
2024-06-12 Y
1899-12-31 N
1945-31-12 N
2000-12-12 Y
2000-13-12 N
2000-12-31 Y
2000-12-32 N
abc 2000-12-12 abc Y
2004-07-03 Y
2004-7-03 N
2004-07-3 N
2004-7-3 N`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}