import Foundation
let pattern = #"((?:19|[2-9][0-9])[0-9]{2})-(1[0-2]|0[1-9])-(3[01]|[12][0-9]|0[1-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1900-01-01 Y
9999-12-31 Y
2024-06-12 Y
1899-12-31 N
1945-31-12 N
2000-12-12 Y
2000-13-12 N
2000-12-31 Y
2000-12-32 N
abc 2000-12-12 abc Y
2004-07-03 Y
2004-7-03 N
2004-07-3 N
2004-7-3 N
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)