# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:19|[2-9][0-9])[0-9]{2})-(1[0-2]|0[1-9])-(3[01]|[12][0-9]|0[1-9])"
test_str = ("1900-01-01 Y\n"
"9999-12-31 Y\n"
"2024-06-12 Y\n"
"1899-12-31 N\n"
"1945-31-12 N\n"
"2000-12-12 Y\n"
"2000-13-12 N\n"
"2000-12-31 Y\n"
"2000-12-32 N\n"
"abc 2000-12-12 abc Y\n"
"2004-07-03 Y\n"
"2004-7-03 N\n"
"2004-07-3 N\n"
"2004-7-3 N")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.