import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{3})\\s(\\w{2})\\s(\\w+)";
final String string = " LMZ333 ALLOTMENT (0000) *TSC\n"
+ "HDQRM5I\n"
+ ".MADRIIB 160846\n"
+ "MADIB HQXL4/MADIB0009/7849644/MAD/IB/A/ES//RC//\n"
+ "1CUVILEON/CARLOS EDUARDO\n"
+ "5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220\n"
+ "5I8327J/IB2194J06JUL MADRZG CS1/1745 2115\n"
+ "OSI 5I CTCP 34606686051-M\n"
+ "OSI 5I POSI-DSAC//MADIB08AB/I/1\n"
+ "OSI 5I CARLOSCUVILIN//GMAIL.COM\n"
+ "= \n"
+ "˜ ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}