use strict;
my $str = ' LMZ333 ALLOTMENT (0000) *TSC
HDQRM5I
.MADRIIB 160846
MADIB HQXL4/MADIB0009/7849644/MAD/IB/A/ES//RC//
1CUVILEON/CARLOS EDUARDO
5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220
5I8327J/IB2194J06JUL MADRZG CS1/1745 2115
OSI 5I CTCP 34606686051-M
OSI 5I POSI-DSAC//MADIB08AB/I/1
OSI 5I CARLOSCUVILIN//GMAIL.COM
=
˜ ';
my $regex = qr/(\w{3})\s(\w{2})\s(\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}