import Foundation
let pattern = #"(\w{3})\s(\w{2})\s(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
LMZ333 ALLOTMENT (0000) *TSC
HDQRM5I
.MADRIIB 160846
MADIB HQXL4/MADIB0009/7849644/MAD/IB/A/ES//RC//
1CUVILEON/CARLOS EDUARDO
5I8397J/IB2198J25JUN RZGMAD CS1/0850 1220
5I8327J/IB2194J06JUL MADRZG CS1/1745 2115
OSI 5I CTCP 34606686051-M
OSI 5I POSI-DSAC//MADIB08AB/I/1
OSI 5I CARLOSCUVILIN//GMAIL.COM
=
˜
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)