#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<ip_addr>((\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|((([\da-fA-F]{1,4}:){7})([\da-fA-F]{1,4})$|(([\da-fA-F]{1,4}:){1,6}:)(([\da-fA-F]{1,4}:){0,4})([\da-fA-F]{1,4}))|(::[\da-fA-F]{1,4})|(([\da-fA-F]{1,4}:){0,7}[\da-fA-F]{1,4}::)))$"
Local $sString = "1.2.3.4" & @CRLF & _
"01.02.3.4" & @CRLF & _
"01.02.03.04" & @CRLF & _
"128.101.1.1" & @CRLF & _
"128.1.101.101" & @CRLF & _
"987.654.321.0" & @CRLF & _
"2607:ea00:101:102:103:104:105:106" & @CRLF & _
"2607:eA00:abcd:efab:cDeF:0000:0000:0001" & @CRLF & _
"fe80::64" & @CRLF & _
"ff02::" & @CRLF & _
"::1" & @CRLF & _
"2001:468::" & @CRLF & _
"" & @CRLF & _
"2001::468::4" & @CRLF & _
":::1" & @CRLF & _
"2001:410:::" & @CRLF & _
"123.123.1a3.313" & @CRLF & _
"1.2.3." & @CRLF & _
".2.3.4" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")