$re = '/^(?<ip_addr>((\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})|((([\da-fA-F]{1,4}:){7})([\da-fA-F]{1,4})$|(([\da-fA-F]{1,4}:){1,6}:)(([\da-fA-F]{1,4}:){0,4})([\da-fA-F]{1,4}))|(::[\da-fA-F]{1,4})|(([\da-fA-F]{1,4}:){0,7}[\da-fA-F]{1,4}::)))$/m';
$str = '1.2.3.4
01.02.3.4
01.02.03.04
128.101.1.1
128.1.101.101
987.654.321.0
2607:ea00:101:102:103:104:105:106
2607:eA00:abcd:efab:cDeF:0000:0000:0001
fe80::64
ff02::
::1
2001:468::
2001::468::4
:::1
2001:410:::
123.123.1a3.313
1.2.3.
.2.3.4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);